The issue has been resolved, and all services are currently functioning as expected. Our team is continuing to monitor system performance closely to ensure ongoing stability.
Posted Jul 02, 2025 - 07:16 CDT
Identified
We’re currently experiencing a disruption in Email Reporting following our latest deployment in the US and CA environments.
What this means for you: Emails are still sending and being received by your recipients as expected. However, you may notice that email reporting data (such as Sent and Delivered counts) is temporarily unavailable.
This issue is isolated to reporting only — there is no impact to your actual email deliveries.
Our team is actively working on a fix and coordinating with our database and development teams to restore full functionality as quickly as possible.
We’ll continue to provide updates as we make progress. Thanks for your patience and understanding.
Posted Jul 02, 2025 - 01:58 CDT
This incident affected: Production Sites (US Production Sites, Canadian Production Sites) and In Application Issues - Severity 1 Defects.