SYSTEM STATUS

Site slowness-US region

Incident Report for Anthology - Encompass

Resolved

This incident has been resolved and it was observed that clients are operating normally.
Posted Mar 27, 2025 - 09:08 CDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 26, 2025 - 11:27 CDT

Investigating

We are experiencing site slowness. This is impacting US region. Our technical team is currently investigating this issue. We will continue to monitor the situation and provide updates.
Posted Mar 26, 2025 - 09:45 CDT
This incident affected: Production Sites (US Production Sites).