SYSTEM STATUS

Encompass Email - Inability to edit drafts/access email history
Incident Report for Anthology - Encompass
Resolved
This incident has been resolved.
Posted Apr 25, 2024 - 09:16 CDT
Investigating
Our team is aware of an issue impacting clients where access to retrieve email history and edit draft emails is impacted in the US. We are currently investigating the issue and will provide an update as we know more.
Posted Apr 25, 2024 - 09:14 CDT
This incident affected: Email Marketing (Email Home).