SYSTEM STATUS

Cloudflare Global Network Experiencing Issues

Incident Report for Anthology - Encompass

Resolved

The service disruption related to Cloudflare is now completely resolved. Cloudflare has confirmed a full restoration of their systems, and we have verified from our end that all services and operations are fully functional. No further action is needed.
Posted Nov 20, 2025 - 17:47 CST

Monitoring

We are aware of an active incident with Cloudflare, one of the network providers used by Encompass. Cloudflare is reporting issues on their global network that are affecting access to the Cloudflare dashboard and related services.

At this time, Encompass remains available and we are not seeing widespread impact to client sites, but there is a possibility that some customers could experience intermittent connectivity issues or page load errors while Cloudflare works through their Issues.

We are actively monitoring Cloudflare’s status updates and Encompass stability. We will update this page if we observe any direct impact to Encompass performance or availability.
https://www.cloudflarestatus.com/
Posted Nov 18, 2025 - 09:08 CST
This incident affected: Production Sites (US Production Sites, Canadian Production Sites, Australian Production Sites).