We are applying a hotfix to address the Image Manager and Document Manager folder loading issue.
Administrators may continue to experience loading issues while the update is being completed and validated. We will provide another update once the hotfix has been applied and normal image and document manager folder access has been confirmed.
Posted Jun 05, 2026 - 09:53 CDT
Identified
We have identified the issue affecting Image Manager and Document Manager folder loading and are working to restore normal access to address the loading issues when accessing files in the image or document manager.
We will provide another update as more information becomes available.
Posted Jun 04, 2026 - 11:10 CDT
Investigating
We are currently investigating an issue where the Image Manager and Document Manager may not load folder contents when administrators attempt to access items inside folders. This may impact adding or editing images and documents in some areas of the platform.
Our team is actively investigating and will provide updates as more information becomes available.
Posted Jun 03, 2026 - 11:39 CDT
This incident affects: Production Sites (US Production Sites, Canadian Production Sites) and In Application Issues - Severity 1 Defects.