SYSTEM STATUS

Email not working - US & CA regions.

Incident Report for Anthology - Encompass

Resolved

Our engineers have monitored the fix and confirmed that Email service is working as expected.
Posted Nov 19, 2025 - 16:03 CST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 19, 2025 - 15:05 CST

Investigating

We are aware of ongoing issue where trying to edit an email in US and CA region gives 500 error and fails to load message variant. Our engineering team is actively working to resolve the issue.
Posted Nov 19, 2025 - 14:55 CST
This incident affected: Email Marketing (Email Home).