SYSTEM STATUS

Secure site errors - Canada Production
Incident Report for iModules Software
Resolved
This incident has been resolved.
Posted 6 months ago. May 05, 2019 - 14:32 CDT
Monitoring
Technical teams have identified the issue and have implemented corrective actions. Technical teams have verified that previously impacted webpages are now loading.
Posted 6 months ago. May 03, 2019 - 15:27 CDT
Update
Technical teams continue to troubleshoot the issue. Updates to follow.
Posted 6 months ago. May 03, 2019 - 15:16 CDT
Investigating
Technical teams are investigating errors on secure webpages.
Posted 6 months ago. May 03, 2019 - 14:58 CDT
This incident affected: Production Sites (Canadian Production Sites).