SYSTEM STATUS

U.S. Production - Corporate Office Power Outage
Incident Report for iModules Software
Resolved
Power has been restored to the corporate office.
Posted 11 months ago. Jul 27, 2017 - 11:01 CDT
Monitoring
There is currently a power outage at our U.S. corporate office. Support teams will be responding to requests via email and answering voicemail. Updates to follow.
Posted 11 months ago. Jul 27, 2017 - 07:43 CDT