SYSTEM STATUS

Encompass Blocker Severity 1 - ENC-37856 Slow loading site pages and admin tools including email
Incident Report for Anthology - Encompass
Resolved
The development team was able to identify and resolve this issue. Site pages and the admin tools should begin loading normally now.
Posted Jun 20, 2019 - 14:21 CDT
Investigating
Slow loading site pages and admin tools including email has been identified as a Severity 1 Blocker Defect and will be reviewed and fixed by our development team as soon as possible. The ticket number for your reference is ENC-37856.
Posted Jun 20, 2019 - 11:47 CDT
This incident affected: In Application Issues - Severity 1 Defects.