SYSTEM STATUS

Scheduled Maintenance - Email Reporting U.S. & Canada
Incident Report for iModules Software
Resolved
Maintenance has been completed
Posted 6 days ago. Nov 11, 2018 - 12:29 CST
Monitoring
We are performing scheduled maintenance on Email Reporting for U.S. & Canada. Email reporting may be delayed or unavailable at times for the duration of the maintenance period beginning 11/9 10:00 PM CT and ending on 11/10 at 10:00 PM CT.
Posted 7 days ago. Nov 09, 2018 - 22:03 CST