SYSTEM STATUS

Severe Weather - Customer Support by Phone
Incident Report for iModules Software
Resolved
Customer Support is now available by phone.
Posted 9 months ago. Feb 07, 2019 - 12:25 CST
Identified
Due to severe weather conditions in Leawood, KS and surrounding areas, Customer support will be available by email and will be returning phone calls as they come in. We will update here once conditions change.
Posted 9 months ago. Feb 07, 2019 - 07:47 CST
This incident affected: In Application Issues - Severity 1 Defects.