SYSTEM STATUS

Encompass Blocker Severity 1 - ENC-38898- Email: Button elements are not clickable in Outlook on Desktop
Incident Report for Anthology - Encompass
Resolved
This issue has been resolved.
Posted Oct 30, 2019 - 10:12 CDT
Investigating
Button elements are not clickable in Outlook on Desktop has been identified as a Severity 1 Blocker Defect and will be reviewed and fixed by our development team as soon as possible. The ticket number for your reference is ENC-38898
Posted Oct 29, 2019 - 09:14 CDT
This incident affected: Email Marketing (EDM).