SYSTEM STATUS

U.S. Email Reporting Delayed
Incident Report for iModules Software
Resolved
The issue impacting Email Reporting has been resolved.
Posted 5 months ago. Nov 16, 2018 - 13:30 CST
Identified
Technical teams are troubleshooting delayed email reporting following scheduled maintenance. Email reporting may be delayed until the issue is resolved. Updates to follow.
Posted 5 months ago. Nov 16, 2018 - 10:43 CST
This incident affected: Production Sites (US Production Sites).