SYSTEM STATUS

Encompass Severity 1 Blocker (ENC-33220) - Canadian Web Services are down
Incident Report for iModules Software
Resolved
Technical teams discovered there was an issue with our Canadian Web Services server. This has been resolved.
Posted about 1 month ago. May 22, 2018 - 11:29 CDT
Investigating
We have identified an issue with our Canadian Web Services. Technical teams are investigating the root cause.
Posted about 1 month ago. May 22, 2018 - 09:15 CDT
This incident affected: Web Services (Canadian Web Services).