SYSTEM STATUS

2/24/18 - Unscheduled Maintenance - U.S. Production
Incident Report for iModules Software
Resolved
The maintenance activity in U.S. production was completed successfully.
Posted 5 months ago. Feb 24, 2018 - 11:42 CST
Monitoring
We will be performing unscheduled maintenance in U.S. Production on 2/24/18 from 12:01 a.m. to 1:00 a.m. CST. There could be up to five minutes of impact during the maintenance activity.
Posted 5 months ago. Feb 22, 2018 - 16:12 CST
This incident affected: Web Services (US Web Services) and Production Sites (US Production Sites).