SYSTEM STATUS

Issue impacting Application Support phones
Incident Report for iModules Software
Resolved
Phone service has been restored for our Application Support team.
Posted 18 days ago. Aug 03, 2018 - 10:29 CDT
Monitoring
We are currently experiencing an issue that is impacting the phone service for our Application Support team. Application Support is able to work tickets and communicate via email. We apologize for the inconvenience and will have an update soon.
Posted 18 days ago. Aug 03, 2018 - 10:02 CDT
This incident affected: Production Sites (US Production Sites, Canadian Production Sites, Australian Production Sites).