SYSTEM STATUS

Cloudflare Data Security Update
Incident Report for Anthology - Encompass
Resolved
This incident has been resolved.
Posted Feb 24, 2017 - 12:59 CST
Monitoring
Cloudflare, our content delivery network provider, experienced an issue that may have caused security issues for its customers. According to Cloudflare, iModules client sites were not affected. We continue to monitor and investigate this issue with Cloudflare to ensure that client sites were not impacted. We will post any available updates on this site.
Posted Feb 24, 2017 - 09:06 CST