SYSTEM STATUS

Encompass - Email Reporting Down
Incident Report for iModules Software
Resolved
This issue has been resolved.
Posted 8 months ago. Mar 07, 2019 - 10:31 CST
Investigating
Encompass email marketing reporting is down and technical teams are investigating.
Posted 8 months ago. Mar 07, 2019 - 06:17 CST
This incident affected: Production Sites (US Production Sites, Australian Production Sites).