SYSTEM STATUS

Issue impacting Toronto Production sites
Incident Report for iModules Software
Resolved
There was an issue with a server that impacted Toronto production sites on 5/9/18 from 6:08 to 6:29 AM CST. Technical teams are investigating the root cause.
Posted 2 months ago. May 09, 2018 - 08:48 CDT
This incident affected: Production Sites (Canadian Production Sites).