SYSTEM STATUS

US Websites - Pages timing out when loading
Incident Report for iModules Software
Resolved
Websites continue to operate normally and technical teams have confirmed resolution of the issue. Our CDN provider experienced an outage at their San Jose, CA network location that impacted regional traffic being routed via San Jose.
Posted 6 months ago. Nov 21, 2017 - 13:33 CST
Update
U.S. Websites have restored to service. Technical teams continue to troubleshoot and monitor.
Posted 6 months ago. Nov 21, 2017 - 12:59 CST
Investigating
We are investigating alerts related to pages timing out. Technical teams are investigating.
Posted 6 months ago. Nov 21, 2017 - 12:42 CST
This incident affected: Production Sites (US Production Sites) and Web Services (US Web Services).