SYSTEM STATUS

iModules Corporate Office Power Outage
Incident Report for iModules Software
Resolved
Power has been restored. Phone support is now available.
Posted about 1 year ago. Aug 22, 2017 - 10:23 CDT
Investigating
There is currently a power outage at our U.S. corporate office. Support teams will be responding to requests via the Support Center, email and voicemail only as there is no phone support at this time. Updates to follow.
Posted about 1 year ago. Aug 22, 2017 - 07:47 CDT
This incident affected: In Application Issues - Severity 1 Defects.